We acknowledge the ongoing impact this issue is having on our users in India. We have made important progress in our contact with the relevant authorities and continue to actively work towards a resolution.
We continue to advise affected customers to use an alternative DNS provider or a VPN as a workaround in the interim. For some customers, custom domains may also be a viable solution. If you have any questions regarding these options, please contact Supabase support.
We will post an update once the issue is resolved or additional information becomes available.
Posted Feb 28, 2026 - 16:02 UTC
Update
We understand many users in India continue to be blocked from accessing Supabase. We acknowledge the difficulties this is causing for our users there. Supabase continues to follow up through all available channels to resolve this issue.
We continue to advise affected customers to use an alternative DNS provider or a VPN as a workaround in the interim. For some customers, custom domains may also be a viable solution. If you have any questions regarding these options, please contact Supabase support.
We will post an update once the issue is resolved or additional information becomes available.
Posted Feb 27, 2026 - 17:39 UTC
Update
Affected customers who are using the Custom Domain feature may be able to restore connectivity by switching their Custom Domain's DNS to an alternative DNS and enabling proxying.
We advise affected customers to continue to report the issue to their ISP.
Posted Feb 26, 2026 - 23:36 UTC
Update
We have received some reports that other ISPs in India may be impacted by access limitations. We continue to follow up through all available channels to resolve this issue. We have engaged multiple teams at Supabase communicating with multiple entities in India in an effort to do all we can to resolve the access issues our users in India are experiencing.
We advise affected customers to continue to report the issue to their ISP and to use an alternative DNS provider or a VPN as a workaround in the interim.
We will post an update once the issue is resolved or additional information becomes available.
Posted Feb 26, 2026 - 14:56 UTC
Update
We continue to follow up through all available channels to work with the ISP to resolve this issue.
We advise affected customers to also report the issue to their ISP and to use an alternative DNS provider as a workaround.
We will post an updated once the ISP has confirmed that the issue is resolved or additional information becomes available.
Posted Feb 25, 2026 - 18:27 UTC
Update
We are currently aware of an issue affecting reachability of Supabase projects for a subset of users based in India. Supabase infrastructure remains fully operational.
We have confirmed that the projects of impacted users remain accessible from regions outside India. Our investigation has confirmed that a service provider in the region is not serving the correct DNS responses for Supabase projects from their internal DNS resolvers.
We are following up through all available channels to work with the ISP to resolve this issue. We also advise affected customers to also report the issue to their ISP.
Alternatively users can use a VPN to avoid this issue
We will post a further update once the ISP has confirmed that the issue is resolved or additional information becomes available.
Posted Feb 24, 2026 - 16:39 UTC
Update
We have confirmed that the projects of impacted users remain accessible from regions outside India. Our investigation is currently focused on an ISP-level block affecting users within India.
We advise affected customers to also report the issue to their ISP. Supabase infrastructure remains fully operational.
We have confirmed that the projects of impacted users remain accessible from regions outside India. Our investigation is currently focused on a potential ISP-level block affecting users within India.
Posted Feb 24, 2026 - 16:00 UTC
Update
We continue to work with customers to address their connectivity issues. We are also contacting the relevant network providers to work with them to resolve the issue.
Posted Feb 24, 2026 - 15:42 UTC
Identified
A DNS resolution issue is affecting customers in AP-South-1 and AP-Southeast-2. Certain ISP DNS servers appear to be unavailable, preventing connections to Supabase endpoints. Some users reported that switching to Cloudflare DNS (1.1.1.1) may restore connectivity. We advise affected customers to also report the issue to their ISP. Supabase infrastructure remains fully operational.
Posted Feb 24, 2026 - 15:13 UTC
Investigating
We have reports of customers having difficulties connecting to Supabase from locations accessing AP-south-1, including a number of reports from India. We are actively investigating the issue.
Posted Feb 24, 2026 - 14:46 UTC
This incident affects: Auth, Edge Functions and Compute capacity (ap-south-1).